This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation Problem
[attachment=60]I bought this program last evening.  I downloaded the manual and read it thoroughly before starting installation.  I followed the installation instructions exactly however, I cannot get the program to run.  I have now tried 8 (eight) times to uninstall and re-install but with no success.

I enclose screenshots of the various error messages I have received along with a screenshot which shows that both the trainer and the flt sim modules are installed successfully.  Can someone please help me with this problem as if I cannot get a resolution I intend to ask for a refund.  

Thank you.

Attached Files Thumbnail(s)
Hello, we are sorry to hear that you are having problems with the TDS GTNXI, we are here to help. Do not worry, we will get this problem solved.

Please make sure that you have only the Aviation PC Trainers Version installed, from this link:

After the installation has completed, please install the GTNXI PC Trainer from here:

We suggest right click and Run As Administrator.
In case the GTNXi PC Trainer does not work, from within the desktop shortcut for the Aviation Trainers, version manager, download and install the GTNXi PC Trainer version 20.20.

Please let us know how it goes.
Thanks for the prompt response.  First of all, I carried out a complete uninstall.

I installed the first link.  On completion, the Launcher opened but the Avionics screen just sat in a continuous loop (screenshot enclosed).

I then installed the second link and got the error message saying that a particular file did not exist (screenshot enclosed)

I then went into Version Manager of the Aviation Trainer Launcher, but there is no option to install version 20.20.  The window states "no packages found"

Looking forward to your next reply.


Attached Files Thumbnail(s)
Hello, we first need to approach this problem from the Aviation Trainer installation. Let's try a different install, please uninstall the existing Aviation Trianer, then delete any remnants, such as these folders:

Where %username% is your username

After which, download, unzip and install (Right Click and run as Administrator):

Please let us know if this step works ok and you get a different result on the Avionics Screen.
Still the same result, I'm afraid.  I get to the Avionics screen and it just sits in a loop.  Similarly, when I go to Version Manager, there is no option to install 20.20.

Perhaps you have multiple user accounts?
No,  I am the sole user.
What we have found out is that there may be a temporary file/fodler that may cause problems, if you navigate here:

Replace %username% with your username

We think that there may be a folder called ".net", it would help if you would delete it and re-run the installation of the Aviation Trainers
First of all, thank you for the efforts you are making to try and solve my problem.

Unfortunately, there is no .net folder in that location.

I should also have said that, in response to you previous post, there was no folder called C:\Users\John\AppData\Local\Temp\Garmin

Can you please email us the log file located here:

Replace %username% with your username


Forum Jump:

Users browsing this thread: 1 Guest(s)