This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Using HDG Mode Question
I only fly the Just Flight Arrow when flying GA in MSFS.

I have the TDS GTNXi v1.0.0.4 installed and because I was getting quite bad jerkiness when using NAV mode, someone suggested its better connecting the GTNXi to the autopilot using HDG mode which I have selected in the GTNXi options page.  However when I load a flight plan in the GTN and select GPS with the CDI button the GTNXi I get a CTD with the GTNXi not MSFS.

Can someone please give me the correct sequence with connecting the JF Arrow autopilot to the GTNXi using HDG mode.

Thanks Glen
Hello Glenn,

We are here to help as much as we can. CTDs are a very serious problem, so let's work on getting them fixed. Are you able to always replicate the issue?

We may have to send you a test version with logging, based on your response.

Do not worry, we will get this problem solved!
Yes it happens every time I select GPS using the CDI button of the GTNXi.
Hello Glenn,

With the TDS GTNXi closed, can you please try deleting the TDSGTN.ini file located here:

Then start the the TDS GTNXi and attempt replicating the problem. Please let us know how it works out.
Sorry about the delay.

I tried deleting the TDSGTN.ini file but that made no difference. I then re-downloaded the TDS GTN Manager, using this uninstalled the GTNXi Flight Sim, then successfully reinstalled the latest version v1.0.0.4.

Started MSFS and loaded the default C172 (non glass instrument version).
Started the TDS GTNXi and selected the GTN750Xi.
Under Settings I selected 'Heading' under Connect GPS to Autopilot.
Then loaded a very simple flight plan in the GTNXi 'EGLK - EGHP - EGHI'
Pressed the CDI button to select GPS while still on the ground and after 4 or 5 seconds the GTNXi CTD

This happens every time.
Hello Glen,

We have sent you a PM regarding this issue. For CTD problems, please post the Windows Event Log Crash details for TDSGTNXiFlightSimEXE.exe
Information on how to access the Event Log can be found here:
I found this info, hope it helps

Faulting application name: TDSGTNXiFlightSimEXE.exe, version:, time stamp: 0x60c19986
Faulting module name: ntdll.dll, version: 10.0.19041.1023, time stamp: 0x7977b9de
Exception code: 0xc0000005
Fault offset: 0x000000000002faad
Faulting process ID: 0x7b8
Faulting application start time: 0x01d766ad86e231fa
Faulting application path: C:\ProgramData\TDS\GTNXi\FlightSimEXE\TDSGTNXiFlightSimEXE.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report ID: a542534c-e093-44b4-b235-f199a4cef2a3
Faulting package full name:
Faulting package-relative application ID:

Can somebody please try this and see if they get a CTD with the GTNXi

Load a default aeroplane in MSFS such as the C172 (non glass cockpit)
Start the engine and turn on the avionics
Start the GTNXi, go to GTN750Xi settings
Where it says Connect GPS to Autopilot, select 'Heading'
In the GTNXi go to Map and ensure VLOC is selected via the CDI switch
Load a very simple flight plan
Select the Map display
Press the CDI to change the mode to GPS

Do you get a GTNXi CTD within about 5 seconds ?
This problem has been confirmed as fixed and will be included in version
Thank you very much for your hard work in rectifying this problem.


Forum Jump:

Users browsing this thread: 1 Guest(s)