This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hello, in Warrrior II, when trying to swtich from VLOC to GPS, it switches briefly, then quickly falls back to VLOC. Even with my course deviation is not so big and I'm fling (in AP HDG mode) towards the 'magenta line'. Is there somethiing I need to do aside from pressing CDI on the map screen to switch between sources?

Thank you,

Attached Files Thumbnail(s)
What happens if you use the Warrior II NAV/GPS switch? Do you have any other software or hardware that might be interfering?

Perhaps a reboot may help?
I'm having the same issue. In the Justflight Warrior II, clicking the CDI button switches to GPS only for a second, and then switches back to VLOC.
Can anybody who owns both the Warrior and another JF Piper confirm that this problem occurs only with the Warrior?
(02-27-2022, 09:39 AM)admin Wrote: Can anybody who owns both the Warrior and another JF Piper confirm that this problem occurs only with the Warrior?

I just tried the JustFlight Piper Turbo Arrow IV and clicking the CDI button switches to GPS mode and stays in GPS mode until I click the CDI button again to switch back to VLOC mode.

So yes, seems to be just an issue with the Justflight Warrior II.
Hello, can anybody else confirm what MatthewS is stating? If yes, we will look into it internally between companies, next week.
Yes, I'm experiencing the same as Matthew. It stays in GPS mode in the Turbo Arrow III and IV, but in the Warrior II it switches back. The NAV/GPS switch on the panel in the Warrior II stays switched but the GTN switches back and displays VLOC; using the panel switch does nothing.
This is with the JF Warrior purchased from the Just Flight store? Is there any way that you can please tell us the exact version number?
The Warrior II was version 3.2 (purchased from the Just Flight Store). I have now installed version 3.3 and it's still the same.

[This is an edited reply - the original said that it was working correctly; however, I was looking at the physical switch. Upon checking it, the GPS display still reverts back to VLOC but still only in the Warrior II - the Turbo Arrows are OK.]
Thank you Rich, this is interesting information, can anybody else confirm what Rich is experiencing?

Forum Jump:

Users browsing this thread: 1 Guest(s)